Jump to content

Custom Search




Photo
- - - - -

Lights and messages...

Traction control Issues Brakes Lights Messages Service

  • Please log in to reply
No replies to this topic

#1 OFFLINE   Msmith5425

Msmith5425

    New Traverse Member

  • Traverse Member
  • Pip
  • 2 posts
  • Gender:Male
  • Location:United States
  • Current Vehicle:2010 Traverse LS

Posted 08 April 2019 - 09:56 AM

Hey everybody.

Ive owned a 2010 Traverse for about a year now and I havent had any issues with it other than having to change a starter, until last month.

About a month ago my wife said it started showing the messages Traction Control Off and Service Brake System messages on the dash. Usually accompanied by the Park Brake light.

I have scoured the vast regions of the internet but I havent found anything on this particular issue. Ive found people showing messages like Service Traction Control and Stabilitrack Off but none with my particular sequence of messages and lights.

The engine hasnt gone into limp mode or Reduced Engine Power yet but Im just waiting for my wife to call me in a panic when it does.

When these mesages come up they vehicle doesnt run or drive any differently. It idles and accelerates the same as well as braking the same. Literally nothing acts any different other than the messages being on the dash display and the audible chime inside the vehicle.

Has anyone experienced this issue or know someone who has? Any advice would be greatly appreciated. Ive checked wheel sensors and brake sensor connections and all seem to be visually ok.






Loose this advertisement by becoming a member. Click here to create a free acccount.





Also tagged with one or more of these keywords: Traction control, Issues, Brakes, Lights, Messages, Service

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·